Monday, November 18, 2013

Pentaho BI-Server 5.0 Community Edition Released

This morning I heard about some exciting news: Pentaho 5.0 CE will be released this Wednesday. I've already been playing around with the development build some weeks ago. The first big difference that you will notice in this release is the new clean web interface, which from my point of view looks a whole lot better than the previous one:


Pentaho User Console and the Admin Console are now finally combined ... no need any more to fire up an extra server to access the admin area!
Pentaho Marketplace really shines in this new release as well ... installing plugins has never been easier!
Under the hood we have a real CMS (Jackrabbit) now - the file-based solution repository is gone (apart from some system files). Content can be uploaded directly via the web-interface or a handy command line utility.
There are many more features, go ahead and check them out here (this link will work as of 2013-11-20). Login details have changed: Joe has retired and is enjoying eternal sunshine on Aruba, your new friend is called admin, and the password is ... you guessed it.
And finally, a big thanks to all the community contributors and Pentaho to make this new release possible!

15 comments:

  1. Hi there!
    I'm testing this new edition 5.0 and have some issues with starting server. All requirements (such as Java) are already installed on my PC. When I run start-pentaho.bat nothing happens and still cannot publish my report, ether login in PUC on 8080 port. Am I doing something wrong? Can you provide me some advice?
    Thank's in advance!
    Regards

    ReplyDelete
    Replies
    1. Did you check the server log for any error message?

      Delete
    2. Where do I check them? In the unpacked folders (biserver-ce) I can't see any logs.. When I hit start-pentaho.bat it pops up cmd screen and it closes after 0.5 sec. Tried to run this bat through cmd but still nothing..

      Delete
    3. Ok, I checked but it was empty.
      Now I have started tomcat with xampp, copied webapps from biserver-ce into tomcat's folder and now when I go to localhost:8080 via my browser I get this message in catalina log:
      WARNING: StandardServer.await: Invalid command ' ' received
      SEVERE: Invalid message received with signature 18245

      P.S. Thank you for helping me ;)

      In browser i get description: The requested resource is not available.

      Delete
    4. Where did you download the bi-server from? It sounds weird that the webapps folder is in the root folder. Or did you move it there initially?

      Delete
  2. I got it from pentaho web http://community.pentaho.com/index.html

    Because I couldn't start tomcat from this download, i started it with xampp (I think it is same thing, tomcat is tomcat), then took webapps from my C:/program files/pentaho/biserver-ce&/tomcat/ and copied whole webapps folder in the C:/xampp/tomcat/

    This server is running on 8080 port so it should be same as tomcat from pentaho installation pack. Maybe I'm doing something wrong with pentaho, tomcat seems to running good

    ReplyDelete
    Replies
    1. Ah, ok, I misunderstood this then. You should try to get it running from within the downloaded package. I read you original message here again ... are you sure you have the correct rights on the batch file? Try to solve this first and do some forum/google search. I haven't worked on Windows for a long time, so I cannot really be a good help in this respect.

      Delete
  3. Diethard, I got it! It works now.. I checked some wiki and found out that enviroment variable PENTAHO_JAVA_HOME was not set.. After I defined it i started pentaho server with provided bat and now I'm in new, well designed PUC :)

    Thank you for your time!

    best regards

    ReplyDelete
  4. Diethard
    I am following your posts and it's wonderful. I am new to Pentaho community editions and currently working on penthao 5 BI CE. I am facing issues like this. I have created a cube on my local machine and now i want to publish it to pentaho BI. Previos versions were so easy to publish. This version, when i publish, it publish even i don't define correct connection and even it don't let me choose the directory where to publish it. Even if i copy the cube manually to pentaho solution directory, it is not showing up in the BI console. Later on when i tried to figure out datasource.xml , i didn't find it. Can you show us the way from start to end for a CUBE publishing to new Pentaho 5.0 community BI server ? I would appreciate and this post will be helpfull to so many people.
    Shreyas

    ReplyDelete
    Replies
    1. You can upload the file via the bi-server web interface or via the import-export script on the command line.

      Delete
  5. I switched my BI Server user and role authentication from jackrabbit to jdbc as I am interfacing with external systems. Got this working fine, but the Administration Console in BI Server 5 is still pointing to the default jackrabbit (??) installation. Do you know where to configure the Admin console to also point to the jdbc database?

    Prior to version 5, the admin console used the same settings as BI Server.

    ReplyDelete
  6. what about add exception to users with specify Roles in this Edition??
    i look if there is way to do this

    ReplyDelete